Titan Two Firmware 1.05-BETA

Official news and announcements from the ConsoleTuner team.

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Thu Sep 19, 2019 1:52 pm

Correct, this is a feature introduced with FW 1.05 (output packets synchronization with USB frame).
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby f00lio » Thu Sep 19, 2019 9:18 pm

J2Kbr wrote:Thanks bone for the feedback.

I was kind expecting some issue with XB1 controllers. The USB descriptors of this controller are configured to 4ms polling rate. However, the input packets are received only at 8ms (as well know) and the FFB/LED packets should be sent at 16ms rate. I have just released a revision of the latest firmware to make the synchronization of FFB/LED packets to the 16ms USB frame, while keeping others output packets types at the default 4ms. This update should fix the issue you reported, please test and let me know.


Does this now mean that using a Xbox elite controller wirelessly with a PS4 will result in 4ms latency vs the 8ms that it always had in the past? If so, that's great!
User avatar
f00lio
Master Sergeant
Master Sergeant
 
Posts: 34
Joined: Wed Jul 26, 2017 1:25 pm

Re: Titan Two Firmware 1.05-BETA

Postby Buffy » Fri Sep 20, 2019 3:40 am

I believe the Xbox One S controller update becomes available if you enroll in the preview program.
ConsoleTuner Support Team || Discord || Custom Scripts
User avatar
Buffy
Lieutenant
Lieutenant
 
Posts: 352
Joined: Wed Jul 20, 2016 5:23 am

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Fri Sep 20, 2019 9:45 am

Buffy wrote:I believe the Xbox One S controller update becomes available if you enroll in the preview program.

:smile0517:
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby Raptor_Titan2 » Sat Sep 21, 2019 11:18 pm

bonefisher wrote:I'm just saying never had orange blinking till your tinkering now with new FW.



Yep i got orange blinking as well. With or without scripts. Kinda worried me for a bit. But read all these discussions.
Thanks guys.
Last edited by Raptor_Titan2 on Mon Sep 23, 2019 12:31 pm, edited 1 time in total.
User avatar
Raptor_Titan2
Sergeant Major
Sergeant Major
 
Posts: 94
Joined: Wed Oct 07, 2015 8:08 pm

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Mon Sep 23, 2019 10:24 am

Last Friday I played for few hours on XB1 and confirmed the output LED occasionally blinks orange, the frequency this happens -it seems- depends on the loaded game.

In any case, there is absolutely nothing to worry. Output buffering were being used since day one, meaning for that blinking milli-second the performance is as the previous FW versions (1.04 and below). For when the LED is solid green, the output is synchronized.

If the blinking orange light is a issue, you can try use the Protocol's Default Polling rate.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Mon Sep 23, 2019 6:47 pm

It was on default and still is on and never had this before I started the BETA firmware!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby DontAtMe » Mon Sep 23, 2019 7:47 pm

bonefisher wrote:It was on default and still is on and never had this before I started the BETA firmware!

From what I understand. The buffering has been present in every firmware,

The only difference between 1.05 and all previous firmware updates, is that the output light will flash orange to notify you whenever any buffering occurs. as opposed to (the older firmware) the Output light staying solid green whenever any buffering occurred.

Unless i am wrong...? As 1.05 has been the only firmware that I noticed the orange lights.
User avatar
DontAtMe
Lieutenant
Lieutenant
 
Posts: 298
Joined: Tue Oct 02, 2018 4:49 am

Re: Titan Two Firmware 1.05-BETA

Postby Scachi » Mon Sep 23, 2019 7:56 pm

DontAtMe wrote:
bonefisher wrote:It was on default and still is on and never had this before I started the BETA firmware!

From what I understand. The buffering has been present in every firmware,

The only difference between 1.05 and all previous firmware updates, is that the output light will flash orange to notify you whenever any buffering occurs. as opposed to (the older firmware) the Output light staying solid green whenever any buffering occurred.

Unless i am wrong...? As 1.05 has been the only firmware that I noticed the orange lights.

That is exactly how I understand it, too. Only new thing is the led showing the buffering. It have been using buffering all the time silently without the LED. As J2kbr said
Also, it is important to say that buffering were being used since day one, so you will not have any detrimental impact on performance (compared with previous firmware) when the output LED is orange.
User avatar
Scachi
Brigadier General
Brigadier General
 
Posts: 2337
Joined: Wed May 11, 2016 6:25 am
Location: Germany

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Mon Sep 23, 2019 8:39 pm

Yeah but started controller disconnects from posts earlier it wasn't just about that and now since I don't have ffb's on it hasn't did it lately! So what ever happened when this started it had the orange led flash come on also!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

PreviousNext

Return to News and Announcements

Who is online

Users browsing this forum: jeepman514 and 4 guests