Titan Two Firmware 1.05-BETA

Official news and announcements from the ConsoleTuner team.

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Tue Sep 17, 2019 3:47 pm

Thank you for testing without script. I was more worried about the controller disconnection, does this still happening without script?

Related with the output led blinking orange, in principle there is nothing to worry. You may be right, the console -for some reason- momentarily stops polling the Titan Two, causing the device to use buffering for the output packets. When this situation is detected, the Titan Two will try re-sync with the console, when the re-sync succeed, the output LED goes back to green. Also, it is important to say that buffering were being used since day one, so you will not have any detrimental impact on performance (compared with previous firmware) when the output LED is orange.

Please let me know: do you have the output polling rate to 1000Hz or "Protocol's Default"?
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Tue Sep 17, 2019 4:50 pm

I still get a taste of something up with rumbles but still get orange led but since I turned off every ffb on ports haven't got disconnected controller. Yes I have output polling at 1000 and input protocol's default .
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Tue Sep 17, 2019 5:51 pm

Ok it is doing it when script is running with no ffb in game or on ports this time!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Wed Sep 18, 2019 8:15 am

Thanks bone for the feedback.

I was kind expecting some issue with XB1 controllers. The USB descriptors of this controller are configured to 4ms polling rate. However, the input packets are received only at 8ms (as well know) and the FFB/LED packets should be sent at 16ms rate. I have just released a revision of the latest firmware to make the synchronization of FFB/LED packets to the 16ms USB frame, while keeping others output packets types at the default 4ms. This update should fix the issue you reported, please test and let me know.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Wed Sep 18, 2019 8:39 am

Ok I'll update and give it a go!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Wed Sep 18, 2019 4:09 pm

So far so good but why are we getting orange flash every 12 to 15 seconds never had that before all this time til now!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Wed Sep 18, 2019 7:33 pm

bonefisher wrote:So far so good but why are we getting orange flash every 12 to 15 seconds never had that before all this time til now!

Awesome. :smile0517:

Related with orange blinking, what can also cause output de-sync is a peak of CPU load on the Titan Two. Maybe your script is doing some heavy processing, causing the Titan Two to miss the opportunity window (approx. 25us) to send the data to the console in time for that USB frame, which ends storing the output data in a buffer to be send in the next USB frame.

Please check if the orange blinking also happens (or not) when not running any script.

Thanks.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Wed Sep 18, 2019 8:50 pm

It's not that because it's blinking with no script running.
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Thu Sep 19, 2019 9:45 am

bonefisher wrote:It's not that because it's blinking with no script running.

Thanks for checking, I principle it is okay get occasional orange blinking, nothing to worry. However, I will be doing a more extensive test with Xbox One to be sure everything is good. :smile0517:
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Thu Sep 19, 2019 12:58 pm

I'm just saying never had orange blinking till your tinkering now with new FW.
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

PreviousNext

Return to News and Announcements

Who is online

Users browsing this forum: No registered users and 6 guests