GTuner intialization problem

Gtuner IV general support. Operation, questions, updates, feature request.

GTuner intialization problem

Postby Hyphen- » Mon May 03, 2021 11:54 pm

GTuner on Windows 10
Titan 2 on ps4
Bluetooth module wireless connection to DS 4

The cord from pc to T2
The cord plugged into PS4

Problem: GTuner does not load scripts saved to T2 memory card is the problem except under certain conditions.

It will only load memory card scripts if GTuner is opened before powering the T2

It will not load the memory card scripts if the T2 is powered by PS4 and then connected to PC with Gtuner opened.

It will not load the memory card scripts if Gtuner is not opened before connecting the T2 with PC being the only power source.

When connecting the GTuner on PC no scripts load unless i remove the usb cord and replug it under these two conditions.

1. if PS4 is on first or
2. if gturner is not opened before making the connection to T2 with the PS4 off. I will have to unplug the usb connection to T2 and re plug it in then they load fine.


This causes me to continuous have to unplug the usb and unplug the ps4 before opening Gtuner.

I can find no settings that change this I have tried to address it here before but no one seems to think this is a thing.

I have real tight usb ports and do not want to plug and unplug this often it will loosen the port.

Thanks for the hard work love the T2 it is awesome this will cause equipment failure more than likely at some point.

One more thing if i use the T2 own power source it will not load memory scripts until i unplug power source and pc then Turn Gtuner on and then connect to T2.

It is obviously choosing to only make a connection on initialization if it is activated after being opened and only be T2 having the PC as only power source. So power is intializing the load only as first power source is PC after GTuner is opened, which if T2 is a switch then this is maybe settings or bad software.
User avatar
Hyphen-
Sergeant Major
Sergeant Major
 
Posts: 68
Joined: Sat Dec 01, 2018 6:30 am

Re: GTuner intialization problem

Postby Hyphen- » Tue May 04, 2021 10:35 pm

The real problem is there is no detailed manual so questions have to be asked here for volunteers who are probably very busy and I am not diminishing anything being done here I am very happy.

I do love all the videos and they have been a great help. And there is lots of information to find.

I really need an electronic electrician to tell me how to alter Gtuner so that it only recognize T2 on demand Not just when the pc is the first power source for the T2 if the PC is not the first power source i have to disconnect and reconnect with Gtuner open for it to recognize the T2.


In Gtuner there are lots of things that someone just buying would have no idea how to use it. Explanations in a game pack are way far more detailed and easy to find than port control errors on the Gtuner. Just a bump...
User avatar
Hyphen-
Sergeant Major
Sergeant Major
 
Posts: 68
Joined: Sat Dec 01, 2018 6:30 am

Re: GTuner intialization problem

Postby Scachi » Tue May 04, 2021 11:08 pm

Try without the sd-card. when its works then format the sd-card.
if you have a sd-card reader you can copy your sd-card content, format the card, copy back the content to keep your existing data.
User avatar
Scachi
Brigadier General
Brigadier General
 
Posts: 2835
Joined: Wed May 11, 2016 6:25 am
Location: Germany

Re: GTuner intialization problem

Postby Hyphen- » Wed May 05, 2021 3:01 am

Okay I can try that and will let you know
User avatar
Hyphen-
Sergeant Major
Sergeant Major
 
Posts: 68
Joined: Sat Dec 01, 2018 6:30 am

Re: GTuner intialization problem

Postby Hyphen- » Thu May 06, 2021 12:58 am

Yikes Help!

I reformatted the sd card but now it says fw not found


Now the device says FW not found and cannot read the bluetooth module
User avatar
Hyphen-
Sergeant Major
Sergeant Major
 
Posts: 68
Joined: Sat Dec 01, 2018 6:30 am

Re: GTuner intialization problem

Postby Hyphen- » Thu May 06, 2021 3:44 am

After at lease 10 attempts to update software to see if that would help. I reformatted the SD several times and tired to put the old files on but everything went haywire. Bluetooth was not working the memory card did not show the files and it would connect to a controller on any port also it kept needed to re-download updates over and over but then one more time and it worked and it was back the way it was before any problems. I think the Titan Fairy visited me but it is working Bluetooth and saved files magically reappeared So the updates fixed it but I have no idea what was going for a while there.

And I now can on demand connect to the T2 with Gtuner...without pulling plugs
User avatar
Hyphen-
Sergeant Major
Sergeant Major
 
Posts: 68
Joined: Sat Dec 01, 2018 6:30 am

Re: GTuner intialization problem

Postby Scachi » Thu May 06, 2021 7:54 am

Pressing that "configure" button in the device configuration pane in GTUner (where you also format the sd-card) is what did fix it for you in the end I think.
After a sd-card format the bluetooth always starts working for me after I press that configure button and power cycle the T2 once after the configure had finished copying the files.
User avatar
Scachi
Brigadier General
Brigadier General
 
Posts: 2835
Joined: Wed May 11, 2016 6:25 am
Location: Germany

Re: GTuner intialization problem

Postby Hyphen- » Thu May 06, 2021 5:31 pm

Maybe... I did have to do that a few times and pulled the SD to see what was loaded when it did not work. I watched the Bluetooth installation video for clues his last comment was you may have to restart Gtuner again to see the results.

One issue was that it looked like it had updated the firmware and software but when it did not work I followed the startup for T2 in program mode and it would download the updates over again after saying it had been updated to the new version each time I did that. So I repeated the startup for the T2 when i saw that it was not sticking and restarted everything and voila' it had all saved files and repeating pairing was not necessary. There is a finicky order to it all kinda fascinating my dad was an electrician who messed with electronics to learn about them... it seems pretty solid when running never glitchy just a straight pass through I will take it. Thanks for the help... much appreciated I saw some nice videos I thought it was your name but was not exactly sure. Cheers :smile0517:

Those updates can feel like J2Kbr to the rescue with an update
User avatar
Hyphen-
Sergeant Major
Sergeant Major
 
Posts: 68
Joined: Sat Dec 01, 2018 6:30 am


Return to Gtuner IV Support

Who is online

Users browsing this forum: No registered users and 7 guests