Titan Two Firmware 1.05-BETA

Official news and announcements from the ConsoleTuner team.

Re: Titan Two Firmware 1.05-BETA (FEEDBACK NEEDED)

Postby J2Kbr » Sat Sep 14, 2019 11:35 am

Completing the packets synchronization update, the revision 6 of the 1.05 beta firmware adds the following:

* BT Stack: Synchronization of I/O packets transmission with the protocol maximum Bluetooth polling rate
* USB Host: Synchronization of I/O packets with the USB frame corresponding to the USB polling rate

With these changes is expected:

- led_set(), ffb_set() and related functions should not cause E4 (out-of-memory) error even if called on every iteration of main().
- Lower latency and better stability for Bluetooth connections (specially with consoles).
- Improvements of the Xbox Wireless Adapter support and wireless connection with XB1 controllers.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby DontAtMe » Mon Sep 16, 2019 8:51 pm

I found an issue with the bluetooth connection.
When I connect my Xbox One controller via Bluetooth.

View (BUTTON_2) is not mapped to anything.
Menu (BUTTON_3) is not mapped to anything.
Right Bumper (BUTTON_4) is mapped to Menu (BUTTON_3)
Left Bumper (BUTTON_7) is mapped to View (BUTTON_2)
So pressing the bumpers results in Menu or View being outputted instead,
and pressing Menu or View results in no input/output.

Basically BUTTON_4 and BUTTON_7 cannot be outputted with a Xbox One controller when connected via bluetooth.
Does not matter what Output the Titan Two is set to.

This issue is only present using the bluetooth connection.
Connecting the controller using the Wireless Adapter or by USB to the Titan Two, work normally.
User avatar
DontAtMe
Lieutenant
Lieutenant
 
Posts: 298
Joined: Tue Oct 02, 2018 4:49 am

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Tue Sep 17, 2019 8:53 am

I have just tested a XB1 S controller here and the mapping is correct. Perhaps your controller is updated with a newer firmware version. I will try update mine and check again. thanks.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby DontAtMe » Tue Sep 17, 2019 11:30 am

J2Kbr wrote:I have just tested a XB1 S controller here and the mapping is correct. Perhaps your controller is updated with a newer firmware version. I will try update mine and check again. thanks.

Thanks,

Also to add, a few more buttons are also effected.

X (BUTTON_17) is mapped to Y (BUTTON_13)
Y (BUTTON_13) is mapped to Right Bumper (BUTTON_4)
Right Stick (BUTTON_6) and Left Stick (BUTTON_9) are not mapped.

I have two Xbox One S controllers on hand, and both are updated to 4.8.1908.0.
User avatar
DontAtMe
Lieutenant
Lieutenant
 
Posts: 298
Joined: Tue Oct 02, 2018 4:49 am

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Tue Sep 17, 2019 1:31 pm

I'm getting a orange flash on the output to console every now and then that shuts controller down. This is normal setup on xbox wired connections!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Tue Sep 17, 2019 1:59 pm

Thanks DontAtMe.

I have just checked my Xbox One S controller and the firmware version is different from yours.
Xbox S Controller.png
Xbox S Controller.png (96.86 KiB) Viewed 242 times

Strangely, it says there is no update available, even after trying update.

With this controller the button mappings are all correct.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby J2Kbr » Tue Sep 17, 2019 2:00 pm

bonefisher wrote:I'm getting a orange flash on the output to console every now and then that shuts controller down. This is normal setup on xbox wired connections!

Do you have any script running? If yes, could you please check if the described issues also happens when using the device without any running script, thanks.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 18796
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Tue Sep 17, 2019 2:27 pm

Ok no script running and took ffb off on all ports plus not doing anything and seen it flash orange split second like maybe xbox is checking or something!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Tue Sep 17, 2019 2:30 pm

Sitting watching it flash orange every 12 to 15 seconds not doing anything with no script!
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

Re: Titan Two Firmware 1.05-BETA

Postby bonefisher » Tue Sep 17, 2019 2:40 pm

I was checking the power source because that was flashing about the same time between port to console and prog port but was not that because plugged DC power jack in and now solid on power source. Still blinking on OUTPUT to console orange led flash every 12 to 15 seconds.
bonefisher
Lieutenant General
Lieutenant General
 
Posts: 5351
Joined: Thu Jan 29, 2015 10:49 am

PreviousNext

Return to News and Announcements

Who is online

Users browsing this forum: jeepman514 and 4 guests