Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Official news and announcements from the ConsoleTuner team.

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby holdinweight » Thu Nov 14, 2019 7:37 pm

J2Kbr wrote:Thank you Buffy and holdinweight for the feedback and inputs.

This morning I tried update all my XB1 controllers using the Win10 App, but it says there is no update available. I will try again on XB1 console. Hopefully some gets updated and I can then reproduce this issue, find the cause and fix.



thanks for your efforts
User avatar
holdinweight
Sergeant First Class
Sergeant First Class
 
Posts: 20
Joined: Tue May 21, 2019 3:47 pm

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby Unjust_Zengetsu420 » Thu Nov 14, 2019 11:38 pm

How's it going. Any luck yet??? Just got the xbes2 controller and im getting the same problem in beta mode
it connects but light shuts off after syncing to the windows 10 wireless adapter and no output
User avatar
Unjust_Zengetsu420
Private First Class
Private First Class
 
Posts: 3
Joined: Thu Nov 14, 2019 11:32 pm

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby 8086 » Fri Nov 15, 2019 2:42 am

I just got my T2 and XBES2 today. I have never used a T2 before.

1. Installed Gtuner on OSX and upgraded firmware to 1.6.1.3 (hot tip for Mac users - Gtuner.cfg is in /Users/YOURUSER/Library/Application\ Support/Gtuner/Gtuner.cfg)
2. I plugged in the XBES2 via cable to A on the T2.
3. I plugged in the T2 via cable to the PS4.
4. Everything worked fine for 3 minutes (didn't get a chance to test the paddles or wireless)
5. After 3 minutes I saw "AU" appear and the XBES2 stopped working.
6. I plugged in the original dualshock to B on the T2. The "AU" went back to "0" and the PS4 made happy noises.

However, the XBES2 has stopped working. Now only the original dualshock works (in B). I have tried:

* Disconnecting and reconnecting the dualshock to B
* Disconnecting and reconnecting the XBES2 to A
* Unplug and replug to T2 to the PS4
* Unplug PS4 power cord and do full cold reboot

Nothing now seems to get the XBES2 working again. Any tips?
User avatar
8086
Sergeant
Sergeant
 
Posts: 8
Joined: Fri Nov 15, 2019 2:27 am

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby DontAtMe » Fri Nov 15, 2019 3:20 am

Make sure your PS4 is using the USB communication method for the controller.

Connect the DS4 to INPUT-B
Wait for the LED to show 0.

Connect the elite controller to INPUT-A.
The output and both Input LED should be green, and both controllers should be functional.

(Note. The DS4 needs to be connected to INPUT-B at all times.)

Also, The share button is mapped to one of the paddles by default, it can be remapped to something else by using the Input Translator or as script.
User avatar
DontAtMe
Lieutenant
Lieutenant
 
Posts: 414
Joined: Tue Oct 02, 2018 4:49 am

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby 8086 » Fri Nov 15, 2019 4:21 am

Wired - After changing the communication method to USB and restarting everything it's working. I installed a script to remap ABXY to paddles. Everything working perfectly.

Wireless - Having various problems with it pairing, seems to require re-pairing often. Doesn't like being unplugged, and twice appeared to lock up (Xbox button very dim, controller unresponsive for many minutes). 10 second long press on the Xbox button seemed to switch it off allowing it to reboot, returning to normal.

Secondly, over bluetooth none of the paddles are now working. RB and LB appear to output option or touchpad. Definitely something screwy going on with mapping only over bluetooth. Any suggestions?
User avatar
8086
Sergeant
Sergeant
 
Posts: 8
Joined: Fri Nov 15, 2019 2:27 am

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby J2Kbr » Fri Nov 15, 2019 5:07 pm

8086 wrote:Wired - After changing the communication method to USB and restarting everything it's working. I installed a script to remap ABXY to paddles. Everything working perfectly.

:smile0517:

8086 wrote:Wireless - Having various problems with it pairing, seems to require re-pairing often. Doesn't like being unplugged, and twice appeared to lock up (Xbox button very dim, controller unresponsive for many minutes). 10 second long press on the Xbox button seemed to switch it off allowing it to reboot, returning to normal.

For wireless usage with the adapter. This will take a little bit longer, I need to have the Elite V2 in hands to reverse engineering its protocol, which seems to be different from the old Elite. There is already an Elite V2 shipped to me.

8086 wrote:Secondly, over bluetooth none of the paddles are now working. RB and LB appear to output option or touchpad. Definitely something screwy going on with mapping only over bluetooth. Any suggestions?

There are some mapping issues when using the controller over Bluetooth. I just saw other topic with more details on this matter. With the info provided there, I may be able to fix the mapping before receive the Elite V2. Will be taking a look on this yet today.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 19213
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby 8086 » Fri Nov 15, 2019 11:13 pm

It's amazing to have such great and responsive support from an active developer/manufacturer. The Elite V2 has only been out a few days and you've already pushed out several firmware updates to support it and got one on its way to you. Thank you!
User avatar
8086
Sergeant
Sergeant
 
Posts: 8
Joined: Fri Nov 15, 2019 2:27 am

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby J2Kbr » Sat Nov 16, 2019 12:04 am

Thank you 8086 for your message and support.

--

I have good news. My S controller got updated on Xbox console, and I was able to reproduce the same issues you guys are reporting: wrong mapping on Bluetooth connection and not working with the Wireless Adapter.

The Bluetooth mapping is already fixed and I am now working on the issue with the Wireless Adapter. If everything goes well, tomorrow we should have a new beta release with the fixes.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 19213
Joined: Tue Mar 18, 2014 1:39 pm

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby XarkonZero » Sat Nov 16, 2019 12:07 am

That's awesome! Echoing previous sentiments, thanks for getting this working so fast! It's an amazing level of dev support.
User avatar
XarkonZero
Private First Class
Private First Class
 
Posts: 2
Joined: Sun Oct 06, 2019 8:30 pm

Re: Titan Two Firmware 1.06-BETA (iOS 13 and Elite V2)

Postby J2Kbr » Sat Nov 16, 2019 1:50 pm

Revision 4 of the 1.06 beta firmware is available.

- Fixed Bluetooth buttons mapping. NOTE: It seems the Elite S2 does NOT reports the paddles as individual buttons over Bluetooth protocol. Will confirm that as soon as I received my Elite S2.

- Fixed Wireless Adapter connection issue with S controllers updated with the latest firmware. I expect this also fix the same issue while using the Elite S2.

Please keep me updated on the results. Thank you.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 19213
Joined: Tue Mar 18, 2014 1:39 pm

PreviousNext

Return to News and Announcements

Who is online

Users browsing this forum: No registered users and 7 guests