Gtuner Crashes when trying to Detect Devices in CV

Gtuner IV general support. Operation, questions, updates, feature request.

Gtuner Crashes when trying to Detect Devices in CV

Postby Squidward » Wed Jan 13, 2021 12:56 am

Submitted GitHub issue: https://github.com/J2Kbr/GtunerIV/issues/399

My setup:

Gtuner IV: 1.10.3.1
Titan Two: 1.10.3.1
MacBook Pro (Retina, 15-inch, Mid 2015)
MacOS 11.1 Big Sur
2.8 GHz Quad-Core Intel Core i7
16 GB ram

T2 > OUT > PC
T2 > PROG > Macbook Pro
PC GPU > HDMI 2.0 cable > AverMedia Live Gamer Ultra capture card > USB 3.1 C to A cable > MacBook Pro
PC GPU > DisplayPort cable > gaming monitor

I am trying to set up my MacBook Pro to do Gtuner CV capture. In Windows, the capture card is recognized as a second display. I can duplicate my display and I can extend it. While it's set to extended, I even set the capture card to output in [email protected] Regardless of whether Windows is set to duplicate display or extend it, and regardless of what resolution I set Windows to output the capture card to while it's in extended mode, Gtuner completely crashes the moment I click on 'Detect Devices' in the Gtuner CV video input config options. It should be noted that no matter which configuration I set Windows to, OBS on my Macbook can detect and use the capture card perfectly.
User avatar
Squidward
Lieutenant
Lieutenant
 
Posts: 397
Joined: Tue Dec 23, 2014 4:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby J2Kbr » Wed Jan 13, 2021 10:06 am

This is an issue related with Big Sur. Gtuner IV is based on Qt framework. Unfortunately, the Qt framework did not receive yet an update to be compatible with Big Sur. I am just waiting that to release new Gtuner IV with support for Big Sur.

Also,I have not tested yet, but it seems you can set a system environment variable named SYSTEM_VERSION_COMPAT to 1 (SYSTEM_VERSION_COMPAT=1) in order to fix some compatibility issues with applications compiled for macOS 10.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 20325
Joined: Tue Mar 18, 2014 1:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby Squidward » Wed Jan 13, 2021 10:14 am

J2Kbr wrote:This is an issue related with Big Sur. Gtuner IV is based on Qt framework. Unfortunately, the Qt framework did not receive yet an update to be compatible with Big Sur. I am just waiting that to release new Gtuner IV with support for Big Sur.

Also,I have not tested yet, but it seems you can set a system environment variable named SYSTEM_VERSION_COMPAT to 1 (SYSTEM_VERSION_COMPAT=1) in order to fix some compatibility issues with applications compiled for macOS 10.


I was actually having this issue while still on Catalina. It was suggested to me that I update macos before any further troubleshooting and updating to Big Sur didn't make any difference.
User avatar
Squidward
Lieutenant
Lieutenant
 
Posts: 397
Joined: Tue Dec 23, 2014 4:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby Squidward » Wed Jan 13, 2021 10:15 am

J2Kbr wrote:Also,I have not tested yet, but it seems you can set a system environment variable named SYSTEM_VERSION_COMPAT to 1 (SYSTEM_VERSION_COMPAT=1) in order to fix some compatibility issues with applications compiled for macOS 10.


Any idea where I do this in MacOS?
User avatar
Squidward
Lieutenant
Lieutenant
 
Posts: 397
Joined: Tue Dec 23, 2014 4:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby J2Kbr » Wed Jan 13, 2021 10:23 am

Squidward wrote:I was actually having this issue while still on Catalina. It was suggested to me that I update macos before any further troubleshooting and updating to Big Sur didn't make any difference.

In this case probably is something else.

Normally when a App crashes on Mac, the OS shows a message with option to generate a crash report. Please save this report to a file and PM me, it will help identify what is the cause of this issue.

Thank you.
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 20325
Joined: Tue Mar 18, 2014 1:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby Squidward » Wed Jan 13, 2021 10:44 am

J2Kbr wrote:
Squidward wrote:I was actually having this issue while still on Catalina. It was suggested to me that I update macos before any further troubleshooting and updating to Big Sur didn't make any difference.

In this case probably is something else.

Normally when a App crashes on Mac, the OS shows a message with option to generate a crash report. Please save this report to a file and PM me, it will help identify what is the cause of this issue.

Thank you.


It's not showing a crash error of any kind. Gtuner changes to all red for a split-second and is then killed. It all happens super fast. It almost looks like I just force quit the application.
User avatar
Squidward
Lieutenant
Lieutenant
 
Posts: 397
Joined: Tue Dec 23, 2014 4:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby Squidward » Wed Jan 13, 2021 6:28 pm

J2Kbr wrote:This is an issue related with Big Sur. Gtuner IV is based on Qt framework. Unfortunately, the Qt framework did not receive yet an update to be compatible with Big Sur. I am just waiting that to release new Gtuner IV with support for Big Sur.

Also,I have not tested yet, but it seems you can set a system environment variable named SYSTEM_VERSION_COMPAT to 1 (SYSTEM_VERSION_COMPAT=1) in order to fix some compatibility issues with applications compiled for macOS 10.


Are you contemplating rebuilding Gtuner based on something other than QT since QT hasn't updated yet after almost 5 months?
User avatar
Squidward
Lieutenant
Lieutenant
 
Posts: 397
Joined: Tue Dec 23, 2014 4:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby J2Kbr » Thu Jan 14, 2021 10:44 am

The Qt framework regularly receives new updates. The 5.15.2 version (used on Gtuner IV) was released on Nov 20th.

Possible the next Gtuner IV release we will be migrating to Qt 6.0
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 20325
Joined: Tue Mar 18, 2014 1:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby Squidward » Thu Jan 14, 2021 10:45 am

J2Kbr wrote:The Qt framework regularly receives new updates. The 5.15.2 version (used on Gtuner IV) was released on Nov 20th.

Possible the next Gtuner IV release we will be migrating to Qt 6.0


Oh, so they've been updating it regularly but haven't released an update with support for Big Sur yet? I'm really hoping to get this working in the next week and a half because that's how little time I have to return my new capture card if I can't ever get it to work. What I don't want is for me to never be able to use the capture card but to end up being stuck with it.
User avatar
Squidward
Lieutenant
Lieutenant
 
Posts: 397
Joined: Tue Dec 23, 2014 4:39 pm

Re: Gtuner Crashes when trying to Detect Devices in CV

Postby J2Kbr » Thu Jan 14, 2021 10:58 am

Correct. The Qt 5.15.2 still on OSX SDK 10.15 (not yet on the Big Sur SDK 11).
ConsoleTuner Support Team
User avatar
J2Kbr
General of the Army
General of the Army
 
Posts: 20325
Joined: Tue Mar 18, 2014 1:39 pm

Next

Return to Gtuner IV Support

Who is online

Users browsing this forum: No registered users and 9 guests